Eclipse SWT drops GTK support of versions less than 2.10


Hey guys,

I have some very exciting news on the GTK-SWT front. Finally, SWT drops support for GTK versions older than 2.10, which means that we will have cleaner code.

I have started cleaning SWT from old GTK code, if you are interested how this work goes, you can follow it here.

Have a great weekend! ;)

Cheers,

Anatoly

About these ads

About Anatoly Spektor

My name is Anatoly Spektor (originally Anatolijs Spektors) I am Software and Web Developer. I have worked in Seneca Center for Development of Open Technology on Big Blue Button Add-on - Polling Module. Currently, I am employed as Software Engineer in Red Hat.
This entry was posted in Eclipse Development, Fedora, My Work, open-source, OS, Red Hat, RHEL, SWT and tagged , , , , , , , . Bookmark the permalink.

2 Responses to Eclipse SWT drops GTK support of versions less than 2.10

  1. John says:

    Nice to know about this news but it could be problematic for old programming codes, which are seeking to upgrade themselves.

  2. laze1989 says:

    Nice to hear. On the same side the GTK3+ integration is going forward. But I still wonder, why Eclipse SWT functions under Windows still better than under GTK :( Especially in Ubuntu it comes with some visiblity issues (like Spacing and marging).

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s